Recommended Deployment Options for Sisense Linux v8.2.4

Applicable to Sisense on Linux

Previous Step

The following recommended options are provided for deployments that use Sisense Linux v8.2.4.

Single Node Deployments

For single node deployments, Sisense recommends you use Sisense Kubespray for Kubernetes with a local second disk on any of the following operating systems, Ubuntu, Rhel, Centos, Amazon Linux 2. To simplify the deployment process, see the single node deployments using Kubespray instructions Initializing Sisense on Linux.

Multi-Node Deployments

For multi-node deployments, Sisense recommends the following deployment options:

Supported Deployment Options

While Sisense is compliant with Kubernetes v1.14-1.17, Sisense strongly recommends using Kubernetes v1.17. The latest versions of EKS and AKS are currently using Kubernetes v1.17.

Sisense V8.2 is certified for the following deployment options:

Single/Multi Location(Cloud Provider) Kubernetes OS(*) Storage Note

Single Node

Any

Sisense kubespray

Ubuntu , RHEL, Centos, Amazon Linux 2

Local second disk

 

AWS

Amazon Elastic Kubernetes Service (EKS)

Ubuntu, RHEL, Centos, Amazon Linux 2

FSx

 

Azure

Azure Kubernetes Service (AKS) - support Basic networking only

Azure CNI is not supported

Ubuntu, RHEL, Centos

NetApp

 

Google Cloud Platforms (GCP)

Google Kubernetes Engine (GKE)

Ubuntu, RHEL, Centos

Google Cloud Filestore

 
Multi-Node

On Prem

Sisense kubespray

Ubuntu, RHEL, Centos

GlusterFS/NFS

 

AWS

Sisense bundled kubespray

Ubuntu, RHEL, Centos, Amazon Linux 2

GlusterFS/NFS/FSx

FSx uses EBS for Mongo ZK

Amazon Elastic Kubernetes Service (EKS)

Ubuntu, RHEL, Centos, Amazon Linux 2

FSx

 

Azure

Sisense Kubespray

Ubuntu, RHEL, Centos

Gluster

 

Azure Kubernetes Service (AKS) - support Basic networking only
Azure CNI is not supported

Ubuntu, RHEL, Centos

NetApp

 

Google Cloud Platform (GCP)

 

Sisense Kubespray

Ubuntu, RHEL, Centos

GlusterFS/NFS

 

Google Kubernetes Engine (GKE)

Ubuntu, RHEL, Centos

Google Cloud Filestore

 

Any

OpenShift

RHEL

GlusterFS/NFS

OpenShift 3.11, 4.0, 4.3.19, 4.4 and 4.5.

Note: FSx and Google Cloud Filestore are encrypted by default.

For more information about Sisense supported Linux deployment options: 

Next Steps